:: Version 3.0.0 ::

Extensions compatibility with iTop 3.0

Last update March 16th 2022.

You will find here is the 3.0 compatibility status for iTop extensions published by Combodo:

Some of the listed extensions are restricted to Combodo's customers.
Get in contact with Combodo if you are interested in them
All extensions versions compatible with 3.0.x, are also compatible with iTop 2.7.x.

Already 3.0 compatible

For these extensions, their latest version is already compatible with iTop 3.0.x
Older versions might well work as well, but were not checked.

Public Extension Version known as 3.0 compatible
All Admin tools delegation 1.0.0
All Assign To Me 0.1.2
All Auto dispatch ticket to a team 1.0.9
All Calendar invitations 1.0.5
All Component details from OCS 1.2.1
All Data archiver simple 1.0.2
All Dispatch Incident to team 1.1.8
All Dispatch User Request to a team 1.1.10
All Embedded webpage in iTop portal 1.1.1
All Location Hierarchy 1.0.1
All Multiple email per contact 1.0.2
All Notify on expiration 1.0.2
All Simple Stock Management 1.0.0
All Data collector Base 1.2.3
All Data collector for LDAP 1.2.7
All Data collector for OCS Inventory 1.0.7
All Data collector for vSphere 1.0.16
Combodo's customer only Auto close Ticket 2.0.2
Combodo's customer only Brute Force Protection 1.0.6
Combodo's customer only Legacy DB views generator 1.0.0
Combodo's customer only OLA per team 0.2.0
Combodo's customer only Portal for business partner 1.0.0
Combodo's customer only Reminder 0.1.1

Upgrade to be 3.0 compatible

A 3.0 compatible version exists for those extensions

You must install the latest version of these extensions before upgrading to 3.0.0

Public Extension Not compatible First 3.0 compatible Version
All DNS Zone Management 2.7.1 3.0.0
All DHCP management 0.2.1 3.0.0
All IPAM for iTop 2.7.1 3.0.0
All IP Request Management 2.7.1 3.0.0
All MAC Address Lookup 1.0.1 3.0.0
All Network Management Extended 1.1.0 3.0.0
All Enhanced global search 1.1.4 1.2.1, but use rather 1.2.4
All Gantt view 1.0.2 1.1.1
All Hyperlinks configurator 1.0.4 1.1.0, but better use 1.1.1
All Make IT VIP 1.1.0 1.2.0
All Time Tracking 2.2.1 2.3.0 but use rather 2.3.2
All Project Management Light 1.0.4 1.1.0
All Project Management Extended 1.0.5 1.1.0
All Data synchronization dashboard 1.1.1 1.2.0
All IFrame Dashlet 1.0.0 1.1.0
All Personal data anonymizer 1.1.0 1.2.0
All Workflow graphical view 1.0.0 1.1.0
All Follow up forms without authentification 1.1.1 1.2.0
Combodo's customer only Alarm console 1.0.3 1.1.0
Combodo's customer only Global Request Management 1.2.1 1.3.0
Combodo's customer only Sharing base 1.0.2 1.1.0
Combodo's customer only Bulk event Management 1.0.0 1.1.0
Combodo's customer only Case Exchange Base (SDK) 1.4.5 1.5.0
Combodo's customer only Kanban board 1.0.3 1.1.0
Combodo's customer only Recuring objects 1.0.5 1.1.0
Combodo's customer only Data localizer 1.2.0 1.3.1
Combodo's customer only SSO SAML 1.0.7 1.1.0

Included in Essential and Professional products

All extensions included in Combodo's products have a 3.0 compatible version. As they are included in the products, there is no upgrade to plan for Combodo's customers.

Public Extension Essential Professional not compatible 3.0 compatible
All Approval process light X 2.0.4 2.1.0
All Calendar view X X 2.0.3 2.1.1
All Communications to the Customers X X 1.1.0 1.2.0
All Approval process automation X 2.0.4 2.1.0
All Configurator for automatic object creation X 1.1.4 1.2.0
All Customer Survey X 2.4.3 2.5.0 but use rather 2.5.1
All Customized request forms X 2.1.5 2.3.0 but use rather 2.3.1
All Predefined response models X 1.1.5 1.2.1
All Database Maintenance Tools X X 2.7.5 3.0.0 (included in iTop now)
All Mail to ticket automation X X 3.3.1 3.5.1
All SLA considering business hours X X 2.2.0 2.3.0
All Send updates by email X X 1.2.2 1.3.1
All User actions configurator X X 1.3.6 1.4.1
Combodo's customer only Log management X X 1.1.0

Other Extensions

If one of your extension is not in this list, check with the extension editor for a 3.0 compatible version.

If there is no way to get one from the editor or from someone else, then:

  • test if it can work with an iTop 3.0 and the latest version of the extension,
  • if not, test if the extension can be removed without damage, it's not always easy

Removal difficulties can come from extension which:

  • add values on existing Attribute Enum → that value must no more be used on any iTop objects (including archived ones!)
  • perform data conversion/migration at installation (in file module.myextension.php) and other tricky database changes which must be manually reverted.
  • add a class under an standard iTop class, then, all instances of that class must be manually deleted from your iTop, before removing the extension. Failing to do this, will result in incoherent database, and broken search, which would be detected by “Database integrity”
  • Existing Dashboards, Query Phrases, Data Source Synchronization,… can break because of an extension removal
  • If other extensions (or the delta.xml from the ITSM Designer) customized objects/menu/methods/… brought by the extension you have removed, this will break as well…
  • Profiles brought by this extension should no more be used by any users (Is it really required to be cleaned before? FIXME)

Extensions included in iTop 3.0

The functions brought by those extensions are now include in iTop 3.0:

  • If you have already install them, you can remove them from /extensions directory or do nothing
  • If you haven't already install them, they will come automatically with your upgrade to iTop 3.0
  • Menu Finder is no more need as the feature is included. Keeping it has no effect on a 3.0+.
  • Multi-LDAP is now included in iTop 3.0. LDAP authentication is a basic of iTop since a while, but the support of multiple LDAP servers is new. If you have already the Multi-LDAP version as a separate extension, you can keep it or remove it, in all cases it won't be used anymore as the one included in iTop 3.0 is a more recent version of the same module.
  • combodo-disable-global-search is no more need as the feature is included. Keeping it has no effect on a 3.0+. This extension was customer only, but the feature is now public
  • Attributes visual beautifier is still required/working for iTop Portal, but it has no effect anymore on the Console. It's a Combodo's customer restricted extension.
  • The 3.0 brings the feature (colors by status) of the above extension for everyone, but limited to the Console.
  • Authentication with SSO SAML is included with iTop Essential and Professional, but not within a Community version. If you have an iTop Product (Essential or Professional 3.0) and have already it as a separate extension, you can keep it or remove it, in all cases it won't be used anymore as the one included in iTop 3.0 is a more recent version of the same module.
3_0_0/release/extensions.txt · Last modified: 2022/09/27 19:59 (external edit)
Back to top
Contact us